•   over 1 year ago

Issue adding my bot to more than one Slack Team

Hi - I'm wondering if others have faced this issue. I've created my bot and have it successfully added and working on Slack. For the submission I'm trying to create another Slack Team where I want to add the bot. I created a new channel in the lex console and successfully followed the instructions to create a second Slack App (since you can only have one Slack team per app). However, once the bot joins the second slack team, it does not respond to any messages (still works fine on the first slack team).

Anyone else facing similar issues?

  • 5 comments

  •   •   over 1 year ago

    Hi Punit,
    Sorry to hear about the issue you faced. This is not a known issue, so it will help us if you could please provide the OAuth URL that was provided to you in creation of second channel. We will try to assist in resolving this issue for you.

    Thanks,
    Saurabh

  •   •   over 1 year ago

    Hey Saurabh, thanks for following up. The Oauth url is https://channels.lex.us-east-1.amazonaws.com/slack/oauth/dafd1d0d-8b4d-4b70-884a-56bfbe53e06c.

    I can also invite you to the slack team if you send me your details to punit.java at gmail.

  •   •   over 1 year ago

    Thanks for sharing this information. Give me some time and I will be back to you on this :)

  •   •   over 1 year ago

    Hi Punit,
    I looked in to this channel that you created on Lex. From our logs it appear that we have been successfully processing the messages for this channel. Can you please check again if this is the problematic channel. If you are ok then we can do a quick chime meeting for this to unblock you. You can share your email and I will send the invite to it.

  •   •   over 1 year ago

    Punit, I have sent you an email. Can you please invite me to the Slack team?

Comments are closed.