•   over 1 year ago

"Unknown error" when trying to export bot definition

Hi all,

Despite the fact that I have set up an IAM user with AmazonLexFullAccess, and am using their credentials, I am unable to export my bot definition using the script provided.

I am getting the following error:
message : '400',
code : 'unknownError',
statusCode : '400',
requestId : undefined,
retryable : false

Has anyone else run into this issue?

Thanks

  • 5 comments

  •   •   over 1 year ago

    I'm also getting the same error. Is there any solutions to this?

  •   •   over 1 year ago

    I am also facing same error. Any other way. I have provided access key and secret also.

  • Moderator   •   over 1 year ago

    It is difficult to know the exact reason for your issue, but one possibility is that your AWS CLI is not set up properly. I would recommend seeing what result you get when you invoke get-bot using the CLI. That may indicate whether your CLI is set up properly or not.

    http://docs.aws.amazon.com/cli/latest/reference/lex-models/get-bot.html

  •   •   over 1 year ago

    Hi,
    It got resolved. Yes it was issue with AWS CLI.
    fixed it ..

    Thanks once again.
    Vishwas

  •   •   over 1 year ago

    Unfortunately I still couldn't get it to work even with the workarounds previously suggested, but CLI was working for me so I manually called get-bot and get-intent and copied the responses to a file.

Comments are closed.